Множественный межсайтовый скриптинг в SquirrelMail

Программа: SquirrelMail 1.4.9

Уязвимость позволяет удаленному пользователю выполнить XSS нападение на целевую систему. Уязвимость существует из-за недостаточной обработки входных данных в параметре "mailto" сценарием webmail.php, в параметрах "session" и "delete_draft" сценарием compose.php, а также из-за ошибки в обработке данных фильтром magicHTML. Атакующий может выполнить произвольный сценарий в браузере жертвы в контексте безопасности уязвимого сайта.

Анатолий Ализар: Бывший автор новостной ленты «Хакера». Увлекается современными технологиями, оружием, информационной безопасностью, носимой электроникой и в целом концепцией Internet of Things.