Программа: PuTTY до версии 0.55 

Уязвимость в PuTTy позволяет удаленному серверу выполнить произвольный код на подключенном PuTTY клиенте.
Уязвимость может эксплуатироваться в SSH2 перед проверкой ключа хоста. Для эксплуатации уязвимости необходимо специальным образом изменить следующие функции в OpenSSH 3.8.1p1: 

packet_put_int
packet_put_string
packet_put_cstring
packet_put_raw
packet_put_bignum
packet_put_bignum2

Оставить мнение