Программа: GuppY 4.5.11 и более ранние версии

Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.
Уязвимость существует из-за недостаточной обработки входных данных в параметре "pg"
сценария "dwnld.php" при записи данных счетчика в ".dtb" файлы. Удаленный
пользователь может с помощью символов обхода каталога перезаписать произвольные
файлы на системе. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc"
должна быть отключена.

Пример:

http://victim/guppy/mobile/dwnld.php?pg=./%2E./statshttp://victim/guppy/dwnld.php?pg=./%2E./test.inc%00

 

Оставить мнение