Программа: Xtreme Topsites 1.1, возможно другие версии.

Уязвимость позволяет удаленному пользователю произвести XSS нападение и
выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в
параметре "searchthis" в сценарии lostid.php, параметре "id" в сценарии
stats.php, и в различных полях в сценарии join.php. Удаленный пользователь может
с помощью специально сформированного запроса выполнить произвольные SQL команды
в базе данных приложения. Удачная эксплуатация уязвимости возможна при
выключенной опции "magic_quotes_gpc".

2. Уязвимость существует из-за недостаточной обработки входных данных в
параметре "searchthis" в сценарии lostid.php. Удаленный пользователь может с
помощью специально сформированного запроса выполнить произвольный код сценарий в
браузере жертвы в контексте безопасности уязвимого сайта.
 



Оставить мнение