Программа: phpVID 1.1

Уязвимость позволяет удаленному пользователю осуществить XSS нападение на
целевую систему и выполнить произвольные SQL команды в базе данных приложения.

1) Уязвимость существует из-за недостаточной обработки входных данных в
параметре «» сценарием search_results.php. Атакующий может выполнить
произвольный сценарий в браузере жертвы в контексте безопасности уязвимого
сайта.

2) Уязвимость существует из-за недостаточной обработки входных данных в
параметре «cat» сценарием groups.php. Удаленный пользователь может с помощью
специально сформированного запроса выполнить произвольные SQL команды в базе
данных приложения.

Эксплоит:

http://www.site.com/groups.php?type=&&cat=4+and+substring(@@version,1,1)=4

http://www.site.com/search_results.php?query=[XSS]

Демонстрация:

http://www.phpvid.com/groups.php?type=&&cat=4+and+substring(@@version,1,1)=4
http://www.phpvid.com/search_results.php?query=<script>alert(0);</script>



Оставить мнение