Более 100 000 сайтов оказались уязвимы перед атаками из-за проблем в Popup Builder, популярном плагине для WordPress, сообщают специалисты компании Defiant. Данный плагин позволяет владельцам сайтов создавать настраиваемые всплывающие окна, содержащие самый разный контент: от кода HTML и JavaScript, до изображений и видео.

Наиболее важный среди обнаруженных в Popup Builder багов получил идентификатор CVE-2020-10196  и набрал 8,3 балла по шкале оценки уязвимостей CVSS. Эта проблема представляет собой stored XSS и позволяет неаутентифицированным злоумышленникам внедрять в любые всплывающие окна на уязвимых ресурсах вредоносный код JavaScript, похищать информацию и, вероятно, полностью захватывать целевые сайты. Уязвимости подвержены все версии Popup Builder вплоть до 3.64.1.

«Как правило, злоумышленники используют подобные уязвимости, чтобы перенаправлять посетителей на сайты с вредоносной рекламой или похищать конфиденциальную информацию из браузеров, но также уязвимость можно использовать для захвата сайта, если  залогиненный администратор посетил или предварительно просмотрел страницу, содержащую зараженное всплывающее окно», — пишут эксперты.

Другая неприятная ошибка в составе плагина (CVE-2020-10195) позволяла любому вошедшему в систему пользователю (с правами простого подписчика) получить доступ к функциям плагина, экспортировать списки подписчиков рассылки, а также экспортировать информацию о конфигурации системы при помощи обычного POST-запроса к admin-post.php.

С релизом Popup Builder версии 3.64.1 уязвимости были устранены, но исследователи отмечают, что пока плагин обновили только около 33 000 пользователей, то есть более 66 000 сайтов с устаревшими версиями плагина по-прежнему остаются уязвимы.

Оставить мнение