Разработчики VideoLan выпустили VLC Media Player 3.0.11 для Windows, Mac и Linux. В составе этого релиза, помимо прочего, была исправлена серьезная уязвимость, допускающая удаленное выполнение команд или приводящая к DoS-атаке на уязвимую машину.

Данная уязвимость получила идентификатор CVE-2020-13428 и представляет собой переполнение буфера в упаковщике H26X. Проблема позволяет злоумышленникам выполнять команды с правами текущего пользователя. Эксплуатация бага требует лишь создания специального файла, который жертва должна открыть при помощи VLC.

Разработчики отмечают, что чаще всего уязвимость провоцирует аварийное завершение работы плеера, однако она может использоваться и для удаленного выполнения произвольного кода и хищения пользовательской информации. ASLR и DEP помогают снизить вероятность такой атаки, но, при желании, атакующие могут обойти эту защиту.

Всем пользователям рекомендуют обновить VLC Media Player до версии 3.0.11 как можно скорее.

1 комментарий

  1. Аватар

    Maxim

    17.06.2020 в 15:44

    Какая прелесть!

Оставить мнение