Программа: Linux-ftpd 0.17 с Linux-ftpd-ssl patch version 0.3

Уязвимость позволяет удаленному
пользователю выполнить произвольный код на
целевой системе. Уязвимость существует из-за
небезопасного использования функции "vsprintf()"
для генерации ответов на запрос FTP клиента.
Удаленный пользователь может создать
большое количество уровней подкаталогов и
в подкаталоге самого низкого уровня
выполнить команду XPWD. Если длина строки
ответа команды превысит 2048 байт, произойдет
переполнение стека.

Оставить мнение