Программа: 427BB 2.2.1 и более ранние версии
 
Обнаруженные уязвимости позволяют удаленному пользователю обойти ограничения
безопасности, произвести XSS нападение и выполнить произвольный SQL команды в
базе данных приложения.

1. Обход ограничений безопасности возможен из-за недостаточной обработки входных
данных в параметрах "username", "authenticated" и "usertype" в файле куки.
Удаленный пользователь может войти в систему под любой учетной записью.

Пример:

Cookie: username=admin;
Cookie: authenticated=1;
Cookie: usertype=admin;

2. Уязвимость существует из-за недостаточной обработки входных данных в
параметре "ForumID" сценария "showthread.php". Удаленный пользователь может с
помощью специально сформированного запроса выполнить произвольные SQL команды в
базе данных приложения.

Пример:

http://host/bb427/showthread.php?ForumID=999%20union
%20select%20UserName,Passwrod,null,null%20from%20prefPersonal

3. Межсайтовый скриптинг возможен из-за недостаточной обработки входных данных в
"url" bbcode теге. Удаленный пользователь может с помощью специально
сформированного запроса выполнить произвольный код сценария в браузере жертвы в
контексте безопасности уязвимого сайта.

Пример:

[url=javascript:alert(123)]clickme[/url]
 



Оставить мнение