Программа: Bitweaver 1.3, возможно другие версии.

Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, получить доступ к важным данным и скомпрометировать уязвимую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "feedback" в сценарии /articles/index.php. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Пример:

http://[host]/articles/index.php?feedback=[code]

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "sort_mode" в сценарии /users/index.php. Удаленный пользователь может получить доступ к названиям таблиц в базе данных и узнать путь к установочной директории приложения на системе.

3. Уязвимость существует из-за недостаточного ограничения на доступ к директории "/temp/articles". Удаленный пользователь может загрузить файлы с несколькими расширениями и затем выполнить их. Для удачной эксплуатации уязвимости должен быть установлен модуль "mod_mime".



Оставить мнение