Программа: Hashcash 1.20, возможно более ранние версии.

Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный ко на целевой системе. Уязвимость существует из-за ошибки распределения памяти в функции "array_push()" в файле hashcash.c. Злоумышленник может вызвать переполнение динамической памяти с помощью большого количества опций командной строки "-r" или "-j", или большого количества имен ресурсов с опцией "-m". Для удачной эксплуатации уязвимости приложение должно быть сконфигурировано на обработку опций командной строки из недоверенных источников.



Оставить мнение