Программа: DigitalWebShop 1.128, возможно другие
версии.

Уязвимость позволяет удаленному
пользователю выполнить произвольный PHP
сценарий на целевой системе. Уязвимость
существует из-за недостаточной обработки
входных данных в параметре "_PHPLIB[libdir]" в
сценарии prepend.php. Удаленный пользователь
может выполнить произвольный PHP сценарий на
целевой системе с привилегиями Web сервера.
Для удачной эксплуатации уязвимости опция
"register_globals" должна быть включена в
конфигурационном файле PHP.

Пример:

http://[host]/rechnung.php?_PHPLIB[libdir]=[file]



Оставить мнение