Программа: Wikkawiki версии до 1.1.6.2

Уязвимость позволяет удаленному пользователю произвести XSS нападение и получить доступ к важным данным.

1. Уязвимость существует из-за некорректного использования функции "strstr()" в функции "Method()". Удаленный пользователь может обойти некоторые ограничения и получить доступ к произвольным php файлам на системе.

2. Уязвимость существует из-за недостаточной обработки входных данных в сценарии /formatters/wakka.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.



Оставить мнение